将设为首页浏览此站
开启辅助访问 天气与日历 收藏本站联系我们切换到窄版

易陆发现论坛

 找回密码
 开始注册
查看: 4272|回复: 1
收起左侧

华为交换机vlan配置

[复制链接]
发表于 2018-10-28 22:24:14 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?开始注册

x
session 1 华为交换机端口模式
: I. S& O0 B$ ^" V一、华为交换机端口分为三种模式:access、trunk、hybird
2 L. F$ x$ m5 y1、access端口,用于连接主机,pvid就是该端口所属的vlan号,只能属于一个vlan2 l' h# V! T8 o4 `
2、trunk端口,用于交换机之间连接,默认pvid是vlan1,不属于任何vlan
7 ^+ Z8 w, U* K" {7 V3、hybird端口,是一种特殊的端口类型,默认pvid是vlan1,不属于任何vlan,是交换机端口的默认模式
) ~7 `8 O' M' C7 p9 C) n二、三种端口的配置命令和解释  z; v# e. S6 p: {8 s
1、access端口vlan属性
8 ?* U6 \" G4 L; D5 V& L' J& i[Huawei-GigabitEthernet0/0/10]display this
8 ], M: w% K6 i* Q7 R. v& s#5 h8 X: k% b, x) y2 f
interface GigabitEthernet0/0/10) F: k1 Z: v, C4 Z" X9 [3 y
port link-type access                                           配置端口的模式为access2 R1 l- o: p- X8 B9 y; c* F
port default vlan 2    端口属于vlan2
% H  j6 [+ F. @  g# t, ^#
- H2 ^$ N# \/ s8 hreturn9 I& p4 Q( }5 [* ]8 X" o
2、trunk端口vlan属性
3 Q) W3 `# l; N/ X# K[Huawei-GigabitEthernet0/0/10]display this 4 r7 S4 B" U% w* L. S. a0 |
#- Q8 F9 v3 ]! i8 `" M" x2 x3 I
interface GigabitEthernet0/0/10  Z5 B, i* H- G1 A; L* R+ h
port link-type trunk   配置端口的模式为trunk' g' w3 v8 R3 d3 s1 H
port trunk pvid vlan 2   配置端口的pvid为vlan2
* t  [: T# ~* [  G1 ]8 \ port trunk allow-pass vlan 2 to 10   配置trunk允许进入的vlan-id,允许vlan1-vlan10(vlan1默认允许)
1 U5 p" `) ]. O/ B#
* m: m  N7 Y% P  Freturn
/ @& u: X. w* e; c! n0 S( ~3、hybird端口vlan属性( Z0 E2 ?8 G- O/ b
[Huawei-GigabitEthernet0/0/10]display this 0 H1 H  c* A, u9 z/ H3 m% h
#
% k7 }% K% L6 h+ `0 z6 T5 m1 S5 Ainterface GigabitEthernet0/0/10 配置端口模式为hybrid8 ]7 S9 I7 ^0 w$ S
port hybrid pvid vlan 2 配置端口的pvid是2  m5 g# ^0 I' W  t
port hybrid tagged vlan 10 配置端口在发送帧时不将帧中的vlan10的标签去掉(类似trunk功能)
6 i3 K; M' ?0 x  a/ `+ ` port hybrid untagged vlan 2 配置端口在接到帧后移除vlan2的标签后转发(给主机)/ D) z1 I$ m% H# K2 c
#5 I% L3 N9 t/ C' u  l+ B; x% J& N' s
return
8 g2 k5 S- f6 Q. [
. _$ M9 D$ x: H# E: S5 k- Ypvid的作用,分为端口接收和发送数据两个方向:
( ~1 R6 n9 I  X1、当端口收到一个未标记的帧时,就把该帧打上vlan id,这个id值等于pvid的值,然后转发到VID和PVID相等的VLAN 中。
3 b: s7 M" g, R' q6 l2、当帧从端口向外发送出去时,如果帧头中的VID和端口的PVID值相同,就把这个标识去掉,再送出去。
/ B) F0 M4 A+ b, t4 I9 \下面例子解释pvid的双向作用:
! s! u# J0 V# a" S
  j# s- z+ l$ }" K2 S. G       整个拓扑中PC1连接在sw1的g/0/1口,vlan1,PC2连接在sw2的g/0/1接口,vlan2
- J  k4 h8 q6 k. K# _       SW1和SW2的g0/0/3接口都是trunk模式,其中sw1的g0/0/3接口的pvid是1,sw2的g0/0/3接口的pvid是2,并且两端trunk都允许vlan 1 to 2的帧通过。1 ?& I, C9 {6 {: W3 k0 U
       这样配置下来的结果是pc1和pc2只要在同一个网段内就可以通信,虽然vlan不同,但是可以通信。
. w% y5 f% @7 ]5 @, ?1、pc1发送数据包给pc2过程是:pc1发送一个去往PC3的数据包到达sw1的e0/0/1接口,由于该接口属于vlan1所以sw1将受到的pc1的数据帧打上vlan1的标签(无标签),然后sw1查找PC3的mac,发现在接口g0/0/3下于是将数据包发给g0/0/3接口,当g0/0/3接口收到这个pc1发来的不打vlan标签的vlan1的帧后,就要将这个不打tag的帧发送出去,发现这个帧的VID和自己的PVID=1是相同的都是vlan1的于是就要把这个帧的tag去掉(vlan1默认就没有tag所以这里不做操作转发出去)然后转发出去。然后这个由PC1发来的帧被sw2在自己的g0/0/3接口收到,sw2发现收到的这个帧是没有tag的普通帧并且trunk接口的配置是允许vlan1、2通过所以会接收这个数据帧,并查看自己的pvid=2,于是就将这个数据包打上vlan2的tag,然后在vlan2的MAC表中查找PC3的mac地址发现在自己的e0/0/1接口上,于是将数据包转发到PC3。3 }0 ?# ]4 i4 B& ]
2、PC3收到PC1发来的数据包后需要给PC1回包,PC3回给PC1的包经过sw2的g0/0/1后被打上了vlan2的tag,到达g0/0/3接口,SW2发现PC3发来的这个帧有tag是vlan2,而自己的pvid=2,于是就将这个tag去掉,而接口又允许vlan1、2通过,于是就将这个去掉了tag的数据包通过g0/0/3接口转发出去,被sw1在g0/0/3接口收到,sw1查看自己的trunk配置发现接口允许vlan1、2通过就接收这个帧,然后检查该帧的VID,发现没有,于是打上vlan1的tag(也就是没有tag),然后在vlan1的MAC表中查找PC1的mac地址,发现PC1连接在自己的e0/0/1接口,就会把帧从e0/0/1接口发送给PC1,这样就完成了一次PC1与PC3的互通。
% s9 `  q2 k' d交换机SW1上的配置:
( a8 |/ l( r. k: p[SW1-GigabitEthernet0/0/3]display this
4 B% i& \$ n( e% f0 I1 I, q#
' w5 r/ X. A/ |+ `' Ninterface GigabitEthernet0/0/32 c5 W: A) ^5 b4 J& v/ d
port link-type trunk& C, Y/ b, ]5 i+ F! @2 X0 C
port trunk allow-pass vlan 2                          端口pvid=1(默认)并允许vlan1、2的帧进入sw1
% f/ }7 p$ R" q1 R, D2 t5 Z9 x#
) V$ H1 E: c% K4 S- zreturn% i+ W, P. g. e% K, ]0 t
[SW1-GigabitEthernet0/0/1]display this ! T2 Q+ T' k# x4 X" U3 m1 S
#
# X5 ]  C3 T7 e- Uinterface GigabitEthernet0/0/1% D  d4 K; r& o& S# ?6 [. b
port link-type access                                     端口默认属于vlan1,连接的是pc18 M/ s: H+ B& C3 ~- z
## V- j) j1 U6 x, m( d- ?
return9 [% w" y% O" w& j& r0 ^) k( Q
交换机SW2上的配置:5 n& j5 E# x0 h9 f
[SW2-GigabitEthernet0/0/3]display this . [/ r; `. I: H7 U
#( H0 G& `9 v5 ~$ B' y3 h( _
interface GigabitEthernet0/0/3# `3 o* {( Z8 F+ Y! n) ~7 F( S# c
port link-type trunk
5 h4 E8 g' g* u4 h/ j. X, v port trunk pvid vlan 2                                   端口的pvid=2            
1 o# V: ?4 A1 F! t port trunk allow-pass vlan 2                         端口允许vlan1、2的帧进入sw2
+ ]5 f% |1 x* a% M# t  u#
7 Y$ E, p$ u- x; e) x. dreturn
2 y& u5 B: j: |. C$ Q; K[SW2-GigabitEthernet0/0/1]display this   F6 [7 N9 \& e# B
#( V3 R9 l; W! t
interface GigabitEthernet0/0/1
* [% }9 o$ V* D# k) |1 R* b* D port link-type access) h& |: \( J/ `6 Y  p) N* w
port default vlan 2                                        端口属于vlan2,连接的是pc2
& v0 y0 o( H! e/ t#
; m1 M" d( j+ d. Ureturn1 o9 K# U2 `! A" {% Y4 d3 h
PC端的配置:
; q+ ?0 \3 Y0 h' \: dPC1:192.168.1.10/247 w9 E5 u, R: B3 D& a' z
PC2:192.168.1.30/244 Z. C2 P1 Z( T0 L: M  j% ^3 g
测试连通性
, j" d/ X$ E. ?: Q0 m  S# tPC1>ipconfig
6 |0 t/ |$ L+ x! ^9 \5 O/ uLink local IPv6 address...........: fe80::5689:98ff:fec3:22c4+ q3 Q: v" f& Q2 r9 Q( ?) ?! ?
IPv6 address......................: :: / 128, r$ Q( O) s" i# E  ?
IPv6 gateway......................: ::
4 s0 s1 p* U  hIPv4 address......................: 192.168.1.10' @& I( l1 \9 q3 w' X" Z8 z" O
Subnet mask.......................: 255.255.255.0
) `0 k+ x3 d4 n4 u& EGateway...........................: 0.0.0.07 X" G: I! i2 _# z3 D( m
Physical address..................: 54-89-98-C3-22-C4
& E9 z5 @2 B2 n2 G3 P7 BDNS server........................:
3 Z: i/ y* M- F( h" UPC1>ping 192.168.1.30
, N) q* r( V0 y5 d, r) b' XPing 192.168.1.30: 32 data bytes, Press Ctrl_C to break
8 Y5 d" v& f8 X2 ?( LFrom 192.168.1.30: bytes=32 seq=1 ttl=128 time=62 ms0 T' l5 k% O. i4 `0 U3 s# ^' K
--- 192.168.1.30 ping statistics ---7 P" U$ D' {( v' l7 ~# |
  1 packet(s) transmitted  S' s8 [8 t3 h, X: y  |4 y4 i
  1 packet(s) received
  S- M6 c( j" J' d  x2 v3 ~7 q. T  0.00% packet loss/ Y- [9 ?0 b3 [" O! w
  round-trip min/avg/max = 62/62/62 ms) p+ T. M# e/ I" @/ S3 G( ~+ x
PC1>
# Y& B/ y. J, g3 r# ~! w2 v: n+ N" d
$ h6 m: p% j0 k( @$ b4 N[Huawei]clear configuration interface g0/0/1      清除接口配置,恢复默认, G- O) w8 r0 ?" w1 {! h

! H7 V- {8 n5 X8 f( ^/ a+ e在hybird模式中的tag和untag:
* [* Q0 m/ _* i7 _. j! O; i. j       tag是指允许通过的tag的帧,功能类似trunk的allow-vlan。untag是指当接口收到帧的时候去除哪个tag,untag=2就是收到vlan2的数据帧后将tag去掉还原成普通的帧(发给主机),类似于access接口的功能。所以hybrid模式是trunk和access接口功能的集合,可以灵活使用。
: N+ ?. b0 w4 q) p5 P+ J下面几个vlan划分的类型来学习hybrid端口的用法:  E1 T# S. N) r: O7 w
1、基于端口的vlan划分,这个就是普通的使用access模式做的,一般都用这个模式
- \# R* v! H8 s4 r0 U' @7 l+ X- T2、基于ip地址的vlan划分,这个是用hybrid模式做,用于主机移动的办公环境(比如公司经常部门调整地理位置),原理是将vlan-id与ip网段进行映射绑定,只要主机的ip网段不变,那么他不管连接那个sw的那个接口都属于同一个vlan,不用担心频繁换地区导致连接sw的端口需要进行vlan的调整
5 l8 X( ]# p* v; f3 K: K
& Q$ U1 p+ Q) v, \4 `0 [* o, }5 V配置如下:, Z9 ]  r% S  p9 j. T) R+ |" ?) e
首先将ip网络与vlan进行绑定,分别在sw1和sw2中创建vlan并绑定相应的ip网段(SW1与SW2配置相同,只以sw1为例)
) \; c$ H' z& ~9 R( h; Lvlan 2
" V4 X+ C# y; X" } ip-subnet-vlan 2 ip 192.168.1.0 255.255.255.0             将192.168.1.0/24与vlan2绑定,红色的数字2是id号,不是vlan号,可以随意设置但是/ ?; |# d+ z2 Z8 }$ H' O5 F
#                                                                                      一个vlan中最多可以绑定最多12个子网网段,只有12个id号
( v: l+ N% R5 Y4 l2 Q配置sw1与sw2的级联trunk端口,并允许所有vlan通过
9 Z8 G9 }5 i. _& d' [, ][SW1-GigabitEthernet0/0/3]display this 0 b8 [9 y: y, I, Y8 `9 M9 @* D
#5 O4 Z! d' f# D$ \
interface GigabitEthernet0/0/3/ p/ N$ b$ T+ D9 v% [7 e
port link-type trunk
8 q6 b; `1 c- Q) t port trunk allow-pass vlan 2 to 4094                          允许所有vlan通过trunk4 ~  w7 w) L0 ?! m
## I: e- d4 Q9 i" J( r) u& {
return$ \0 q  V' W/ E/ S0 w" O
配置sw1连接PC的g0/0/1端口为hybrid模式,并且只允许vlan2的数据帧通过(去除vlan2的标签给pc,收到其他vlan的数据就不会去掉标签直接发给pc,而pc不能识别带有vlan标识的帧从而丢弃数据帧,达到将pc的ip绑定在vlan2中)8 L9 e! u; H( C+ w$ K  i
[SW1-GigabitEthernet0/0/1]display this 8 H. @" R  R8 q* J
#
' o! R( T1 o4 j3 P$ E0 }6 ginterface GigabitEthernet0/0/1/ r! K9 h: Q0 ]' g3 n. {  O
port hybrid untagged vlan 2                                      在发送帧(给PC)时只去掉vlan2的标签(带有其他vlan的帧不会去掉标签)! t! q! ^0 E  J0 d3 I! O; @6 z
vlan precedence ip-subnet-vlan                                配置优先使用基于ip划分的vlan模式(默认使用基于端口的vlan模式)4 r: m) p9 ?  U5 V. W4 L
ip-subnet-vlan enable                                                启用基于ip网络的vlan划分; M% H& [# B: L# i
#0 L4 a! @+ q! ?; X  F6 x
return9 O# l# O% ]6 x
       验证方法是将sw1或者sw2的g0/0/1端口port hybrid untagged vlan 2修改为其他vlan-id后pc之间就无法通信,可以抓包查看帧的vlan-id。或者将pc1与pc2的ip地址改为192.168.2.x也不通,是因为vlan2只绑定了192.168.1.0/24而没有绑定其他网段,而端口又只untag了vlan2的帧。
/ t0 r- U. v8 V; @5 c- E& }3、基于mac地址的vlan划分,与基于ip的vlan划分一样使用hybrid模式做,功能和基于ip地址的vlan划分类似- C$ \8 A% z1 {9 k7 y
首先将pc的mac地址与vlan绑定,SW1与SW2配置相同,在vlan2中绑定pc1和pc3
2 E# y( D& h1 M  F, N3 o- Mvlan 2                              - x% q" H5 A$ x6 g4 A0 W$ O
mac-vlan mac-address 5489-98c3-22c4 priority 0' k0 f3 q& A( ]
mac-vlan mac-address 5489-98ce-1433 priority 09 j2 C% H' z7 y) k# r% F
配置sw1与sw2之间的trunk端口,允许所有vlan帧通过! Q/ a, h1 b! g
interface GigabitEthernet0/0/3
# I, H% e4 x) f/ u port link-type trunk5 G7 Q' p- c$ I0 J2 n( `1 q
port trunk allow-pass vlan 2 to 4094: U, j' F, s6 G$ C. K) R- ~
#
5 M% y7 Z4 Y  e% @配置sw连接pc的接口的vlan模式优先使用mac划分vlan模式(hybrid端口默认就是mac-vlan模式),开启基于mac地址的vlan划分/ j( y* Z: ~0 d
interface GigabitEthernet0/0/1
* j6 M) h9 J; I% w port hybrid untagged vlan 2                           允许vlan2的帧通过,在发送帧(给PC)时只去掉vlan2的标签(带有其他vlan的帧不会去掉标签)
9 E4 w! L( e! y" a+ i6 r mac-vlan enable                                              开启基于mac地址的vlan划分
. G5 O& W6 r3 `8 N#1 f# d# u: |( ~& @2 w
       验证方法与基于ip的vlan划分一样,或者可以将pc1与pc3改为其他网络,依然能通信,是因为使用的是基于mac的vlan划分,所以只要mac在一个vlan内,那么不管ip如何变化只要在一个网段内都能通信。
- f$ K: p. ?3 H' k- X: Z2 g' H$ t
  Y, V$ a6 \( ?8 ?+ h
 楼主| 发表于 2018-10-28 22:25:01 | 显示全部楼层
步骤:7 r8 Q/ ]8 x  u! n9 o0 `: j
; E" E+ D0 j1 B( M' h3 G, v7 t1 q  H
1.telnet 登录到交换机到控制台* e4 e0 w8 y% J" Y" X  b! L

+ x' Q/ d4 V; k+ v+ f8 A9 l0 z2.进入系统视图,创建 2到20的vlan0 i, F* a1 b- h+ d8 W7 W5 Q+ K

; l* \) W& B6 ^1 E* d, ^0 n<Quidway>sys3 V! h3 F; N- g
Enter system view, return user view with Ctrl+Z.9 `. s0 r7 e. Z: [4 W) @
[Quidway]vlan batch 2 to 20% R+ q0 l) Y: J% V2 r
Info: This operation may take a few seconds. Please wait for a moment...done.9 K; \/ O3 _  [4 Y* }; r. {
[Quidway]% B; J' V* r, H3 Q( m/ j
7 s5 t# c! S' n: e$ |0 }" V
3.进入37口
( h- F$ k; s% w5 z5 ~  z" T& h2 v7 m+ ~
[Quidway]int g0/0/37
9 B$ _! Y" k3 u* d0 M) C" X' @9 J[Quidway-GigabitEthernet0/0/37]
7 r% g% _" x; D1 S6 P. v
2 \% t" O+ @/ l4.设置trunk, t7 M& @2 N  W3 Y+ x

$ l$ ?2 x0 {- B/ Y- U+ }4 R[Quidway-GigabitEthernet0/0/37] port link-type trunk! S! S6 C" E' c7 X* X

) k% Z" P2 E/ O3 P! D0 k[Quidway-GigabitEthernet0/0/37] port trunk allow-pass vlan 2 to 4094. o( j" Q: `1 u

: q  X6 {- j/ {5 ~* J: J2 tInfo: This operation may take a few seconds. Please wait for a moment.....done.% J: q8 }) u; U4 `, [
[Quidway-GigabitEthernet0/0/37]
) s1 S2 l* U4 G& ?
: y- Y8 U6 A0 S5.查看
: k8 s) @. g8 a4 @& h3 n# H
& p; y, M  ]  d2 Q: @2 p" d- J8 D- X[Quidway-GigabitEthernet0/0/37]dis this' T, t, O1 I$ r" q6 z
#
4 B9 c, z2 m9 `# Kinterface GigabitEthernet0/0/37
8 u5 t7 K7 ^! y; j port link-type trunk5 K; b8 r( z; V. ]
port trunk allow-pass vlan 2 to 40943 G+ t5 g+ t( y" W( P
#1 U$ u  Y9 N% E4 }+ E3 L& z
return
. l, L, u) a! E* e# T) L[Quidway-GigabitEthernet0/0/37]
$ `1 u6 @* N/ \. `: o4 q$ d: Q0 o- n$ h! X9 V! B* ?+ i
6.38口设置参照以上3、4、5操作即可
) K+ R0 B7 {! h7 t7 y% n8 I" T
/ o' N) R$ ]% }( P5 f+ g8 m7.保存设置
/ C2 D% u* s0 W# h+ ], J
8 O! }( b1 r! }
, E1 W! ~3 X: S; a% v# b交换机配置好后,如果不保存,交换机断电或者重启后,配置就会丢失。
# X! b, c) q+ }. r$ P! T' ?% a3 _3 P( H所以,在配置好交换机后在  用户视图 执行 save  命令,就可以将配置保存到交换机上了。 注意必须是用户视图<Quidway>执行save命令。+ X: v+ d% Y# Y1 I: h
[Quidway]quit
7 T; `6 h. \' j8 n$ m% T<Quidway> save: V( C. e" \0 b8 X

: q! A# _7 ~  a/ D0 Y
您需要登录后才可以回帖 登录 | 开始注册

本版积分规则

关闭

站长推荐上一条 /4 下一条

如有购买积分卡请联系497906712

QQ|返回首页|Archiver|手机版|小黑屋|易陆发现 点击这里给我发消息

GMT+8, 2022-12-10 09:59 , Processed in 0.043693 second(s), 22 queries .

Powered by LR.LINUX.cloud bbs168x X3.2 Licensed

© 2012-2022 Comsenz Inc.

快速回复 返回顶部 返回列表